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1 Открываем две фотографии животных – изображения собаки и 
тропического попугая.

2 Одним из инструментов выделения, например, Magic Wand или/и 
Lasso) отделяем от фона голову собаки и копируем ее (Ctrl+C).

3 Закрываем фотографию собаки и помещаем скопированную об-
ласть на снимок с попугаем (Ctrl+P).

4 Пусть вас не смущают разные пропорции животных – это легко ис-
править. Применяем к слою с головой собаки команду Scale (меню 

Edit>Transform>Scale). Удерживая клавишу Shift, уменьшаем голову со-
баки до нужного размера.

6 В панели управления Layers снижаем непрозрачность (Opacity) 
слоя собаки до 70%: так мы будем  видеть слой с попугаем.

5 При необходимости можно изменить и поворот головы. Для этого 
применяем команду Rotate (меню Edit>Transform>Rotate).
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8 Теперь необходимо избавиться от клюва птицы, проступившего 
из-под слоя с головой собаки. Переходим к слою Background и 

инструментом клонирования (Clone Stamp) выбираем исходный учас-
ток клонирования из фона фотографии. Несколькими щелчками мыши 
производим клонирование, заменив клюв попугая на зеленую листву 
фона.

9 Теперь – самое интересное. Нужно заменить шерсть на голове со-
баки на птичьи перья. Для этого на слое с фотографией попугая вы-

бираем область для клонирования (перья), а затем переходим к слою с 
головой собаки и с помощью инструмента клонирования приступаем к 
замене.

10 Важно следить, чтобы узор не повторялся слишком отчетливо, 
а области пасти собаки, уха и глаза оставались нетронутыми. 

Чтобы смягчить границы у этих областей, можно снизить непрозрач-
ность инструмента клонирования до 70%.

11 Основная часть работы готова, но нужно проработать и детали. 
Так, мы собираемся перенести узор, обрамляющий глаз по-

пугая, на собачью голову. Делаем невидимый слой с головой собаки, 
щелкнув по пиктограмме глаза в панели управления Layers, и выделяем 
инструментом Lasso область вокруг глаза попугая.

12 Копируем выделенную область, переходим обратно к слою с го-
ловой собаки и помещаем ее поверх собачьего глаза.

7 Мягким ластиком (Eraser) аккуратно стираем  ненужные облас-
ти слоя с головой собаки и возвращаем непрозрачность слоя на 

100%.
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13 При необходимости можно повернуть или растянуть новый 
слой, чтобы он лучше совпадал с нижним. Снижаем непрозрач-

ность слоя в панели Layers до 70% и командами Rotate и Free Transform 
подгоняем участок под нижнее изображение.

14 Ластиком стираем все лишние участки. Чтобы границы полу-
чились плавными, непрозрачность кисти можно уменьшить до 

80%. Также можно стереть  глаз попугая, открыв «прорезь» для собачь-
его глаза, который будет просвечивать из нижнего слоя.

15 Возвращаем непрозрачность слоя на 100% и склеиваем верх-
ние два слоя либо командой Merge Down в панели управления 

Layers, либо нажав Ctrl+E.

16 Чтобы еще больше сгладить границы, воспользуемся инстру-
ментом Patch Tool. Постепенно выделяя области границы, пере-

таскиваем выделение на участок с перьями птицы – он мягко растворит 
контуры.

17 Инструментом клонирования заполняем область над глазом 
«птичьим» узором.

18 Теперь приступаем к работе с ухом собаки. Прежде всего его 
необходимо сделать красным. На слое с головой собаки выде-

ляем ухо инструментом Lasso и/или Magnetic Lasso.
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19 Применяем к выделенной области команду Variations (меню Im
age>Adjustments>Variations). В открывшемся окне постепенно 

добавляем красный оттенок, пока ухо у собаки не станет по цвету таким 
же, как перья попугая.

20 Убираем выделение (Ctrl+D). Мягким ластиком аккуратно про-
ходимся по внешнему контуру уха, а инструментом клонирова-

ния с непрозрачностью 70% подправляем внутреннюю границу.

21 Теперь необходимо придать изображению рельефность. Для 
этого выбираем инструмент Burn Tool, устанавливаем область 

воздействия (Range) на Shadows, а силу воздействия (Exposure)  – на 
30%.

22 Теперь аккуратно проходимся инструментом по тем областям, 
которые следует слегка затенить.

23 Для еще более реалистичного эффекта нужно высветлить вы-
ступающие области. Для этого настраиваем инструмент Dodge 

Tool следующим образом: область воздействия (Range) на Highlight, а 
силу воздействия (Exposure) – на 30%.

24 Подчеркиваем области, которые необходимо высветлить. Едва 
заметный на первый взгляд эффект намного улучшает впечат-

ление от изображения и делает его более реалистичным.
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25 Осталась самая малость – окончательно подретушировать 
границы слоя с головой собаки. Увеличиваем изображение и 

мягким маленьким ластиком с непрозрачностью 60% проходимся по 
границам головы собаки.

26 В панели управления Layers объединяем оба слоя командой 
Flattern Image.

27 Коллаж готов!
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Древесная текстура
В этом уроке мы рассмотрим, как создать реалистичную 
текстуру дерева в программе Adobe Photoshop CS. В этом 
нам поможет несколько нестандартный подход к исполь-
зованию фильтров, а также работа со слоями и многие 
другие возможности программы. Использовать такую тек-
стуру можно в самых разных случаях, главное — как можно 
более точно воссоздать всю сложность рисунка древеси-
ны: волокна, кольца и прожилки. äéåèúûÄêíA
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1 Создаем новый файл. Размер его зависит от того, к чему вы 
собираетесь впоследствии применить данную текстуру.

2 Создаем новый слой и устанавливаем цвет фона и основной цвет 
на темный и светлый оттенки коричневого — такие цвета будут у 

фона для древесной текстуры.

3 Применяем к новому слою фильтр Clouds (меню Filter > Render > 
Clouds).

4 Применяем к этому же слою фильтр Polar Coordinates (меню Filter 
> Distort > Polar Coordinates), установив параметр на Polar to 

Rectangular.

6 Создаем еще один слой и заливаем его с помощью инструмента 
Paint Bucket Tool основным цветом (выбранным ранее светло-ко-

ричневым).

5 С помощью команды Free Transform (меню Edit > Free Transform 
или Ctrl+T)  изменяем масштаб верхнего слоя так, чтобы текстура 

более или менее равномерно распределилась по всей поверхности 
изображения.
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8 Используем еще один фильтр — Motion Blur (меню Filter > Blur > 
Motion Blur). Угол (Angle) должен составлять 90°, а параметру 

Distance следует задать значение 50.

9 Применяем к слою команду Scale, вытягиваем верхний и нижний 
его края так, чтобы избавиться от граней, образовавшихся после 

использования фильтра Add Noise.

10 Непрозрачность (Opacity) слоя Layer 1 должна составлять до 80%, 
а режим наложения слоя Layer 2 следует изменить на Hard Light.

11 Создаем еще один слой и на нем рисуем с помощью инструмен-
та Line Tool темно-коричневым цветом несколько линий разной 

толщины (толщину линий указываем в строке параметров вверху стра-
ницы). Чтобы линии получались ровными, удерживаем клавишу Shift.

12 Применяем к этому слою команду Rasterize Layer (меню Layer >  
Rasterize), а затем фильтр Wave ( меню Filter > Distort > Wave). При-

дется поэкспериментировать с параметрами, чтобы добиться реалистичных 
древесных прожилок, — все зависит от первичного размера изображения.

7 Применяем к этому слою фильтр Add Noise (меню Filter > Noise > 
Add Noise), установив Distribution на Gaussian, выставив галочку на 

параметре Monochromatic и выбрав величину (Amount) в 15%.
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13 Изменяем масштаб слоя (меню Edit > Transform > Scale) и пере-
двигаем слой так, чтобы все пустые области, образовавшиеся 

на линиях после использования фильтра Wave, остались за рамками 
изображения.

14 Применяем к слою с линиями фильтр Add Noise с параметром 
Amount в 30%.

15 Применяем фильтр Motion Blur с параметром Distance в 15 пик-
селов.

16 Дублируем верхний слой (меню Layer > Duplicate Layer).

17 Применяем к верхнему слою фильтр Gaussian Blur (меню Filter > 
Blur > Gaussian Blur).

18 Снижаем непрозрачность слоя (Opacity) в панели управления 
Layers до 50%.
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19 Дублируем слой Layer 1.

20 Перемещаем слой Layer 1 в панели управления Layers над все-
ми слоями.

21 Изменяем режим наложения слоя на Hard Light.

22 Теперь можно объединить все слои командой Flatten Image.

23 При желании можно изменить общий тон древесины. Для этого 
открываем диалоговое окно команды Variations (меню Image > 

Adjustments > Variations).

24 Также можно слегка изменить настройку уровней (Levels), что-
бы сделать текстуру дерева более контрастной или, наоборот, 

смягчить линии.
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25 И последний штрих: дублируем слой и применяем к нему фильтр 
Motion Blur, установив значение Distance в 55 пикселов.

26 Выбираем режим наложения слоя Overlay и слегка снижаем его 
непрозрачность.

27 Объединяем оба слоя — и древесная текстура готова!
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Озаренные
светом

В этом уроке мы рассмотрим, как 
с помощью Adobe Photoshop CS 
создавать реалистичный источник 
света и рассеянные лучи. Этот при-
ем позволяет превращать самые 
обычные фотографии в цифровые 
картины, исполненные таинствен-
ности.äéåèúûÄêíA
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1 Создаем новый файл с белым фоном

2 Открываем изображение, которое собираемся использовать в ка-
честве основы. В нашем случае это фигура девушки.

3 С помощью инструмента Magnetic Lasso отделяем изображение 
девушки от фона. Magnetic Lasso автоматически расставляет точки. 

Если вас не устроит та или иная точка, нажмите Delete или Backspace, 
и она сотрется. Постепенно создавая контур с помощью этого инстру-
мента, можно регулировать область выделения следующим образом: 
один щелчок задает новую точку, а двойной щелчок закрывает область 
выделения.

4 Если внутри основного контура фотографии еще остались невыде-
ленные области, то следует выделить и их. Удерживая клавишу Alt, 

инструментом Magnetic Lasso обводим оставшиеся области.

6 Перемещаем изображение девушки на новом файле вниз и сохра-
няем его. А тот файл, откуда мы только что скопировали фигуру де-

вушки, теперь можно закрыть.

5 Копируем выделенную область и помещаем ее в созданный ранее 
новый файл.
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8 Инвертируем цвета изображения (меню Image > Adjustment > 
Invert Image или Ctrl+I).

9 Создаем новый слой (меню Layer > New Layer).

10 Щелкаем по инструменту градиента на панели инструментов, 
после чего вверху экрана появляется панель управления гра-

диентом. Щелкаем по градиенту — открывается панель параметров 
Gradient Editor, позволяющая модифицировать по своему усмотрению 
существующие градиенты и создавать новые.

11 Нам понадобится создать градиент от бледно-желтого до тем-
но-оранжевого. Для этого выбираем любой существующий 

двухцветный градиент и заменяем цвет в начале линейки на бледно-
желтый, а цвет в конце линейки — на коричнево-оранжевый.

12 Теперь в панели управления градиентом выбираем Radial 
Gradient и применяем его к новому слою от той точки, из кото-

рой должны исходить лучи света.

7 Применяем команду Flatten Image (меню Layer > Flatten 
Image), чтобы объединить два слоя в один.
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13 В панели Layers меняем режим наложения слоя на Linear Light, а 
непрозрачность (Opacity) уменьшаем до 90%.

14 Теперь — главное: будем рисовать сами лучи. Переходим в ре-
жим быстрой маски, нажав клавишу Q, и инструментом пера ри-

суем контуры лучей, расставив треугольниками точки от места источни-
ка света до границ изображения.

15 Создаем еще один новый слой (меню Layer > New Layer).

16 Переходим к панели Paths и, щелкнув правой кнопкой мыши по 
пути (лучи), создаем область выделения (Make Selection).

17 Снова открываем панель параметров Gradient Editor и редак-
тируем градиент так, чтобы цвет в начале линейки был чисто 

белым, а потом постепенно переходил в прозрачный. Для этого щелка-
ем по верхнему ограничителю, отвечающему за непрозрачность цвета 
(Opacity stop), и снижаем параметр Opacity до нуля.

18 Применяем этот градиент к новому слою — опять от источника 
света.
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19 В панели Layers меняем два верхних слоя местами, перетащив 
Layer поверх другого.

20 Инструментом Rectangular Marquee Tool создаем прямоуголь-
ное выделение так, чтобы источник света снова оказался при-

мерно в середине.

21 Применяем к выделенной области фильтр Motion Blur (меню 
Filter > Blur > Motion Blur) и убираем выделение (меню Select > 

Deselect).

22 Как и раньше, создаем новый слой, выделяем путь в панели 
Paths (Make Selection) и заливаем его градиентом от белого к 

прозрачному.

23 Снова выделяем прямоугольную область, но на этот раз приме-
няем фильтр Radial Blur (меню Filter > Blur > Radial Blur).

24 Выходим из режима быстрой маски (клавиша Q) и большой 
мягкой кистью белого цвета с низким параметром Opacity под-

черкиваем самые выступающие части изображения, показав, что свет 
лучей падает и на нижнюю часть.
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25 Объединяем все слои в один командой Flatten Image (меню 
Layer > Flatten Image).

26 Можно слегка подкорректировать уровни (меню Image > 
Adjustments > Levels), повысив контрастность изображения.

27 И наконец, можно изменить цвета в изображении — проще все-
го сделать это при помощи Variations (меню Image > Adjustments 

> Variations).



Марго Григорян
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1 Откроем фотографию. Идеально подходят снимки скал или камен-
ных сооружений с интересной текстурой и перспективой.

2 Сдублируем слой в панели Layers (или в меню Layer>Duplicate 
Layer).

3 Применяем к новому слою команду Desaturate (меню Image>Adjust
ments>Desaturate или Shift+Ctrl+U).

4 Теперь к этому же слою применим фильтр Gaussian Blur с радиусом 
размытия в 7 пикселов (меню Filter>Blur>Gaussian Blur). В панели 

Layers щелкнем по пиктограмме глаза, чтобы сделать этот слой неви-
димым.

6 На новый слой поместим изображение, рельеф которого нужно 
впоследствии перенести на поверхность пирамиды. Заливка изоб-

ражения должна быть черной, а чем четче и проще будут контуры ри-
сунка – тем лучше.

5 Создадим новый слой.
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8 Изменим режим наложения слоя на Overlay.

9 Применим к верхнему слою фильтр Diffuse Glow (меню Filter>Distort> 
Diffuse Glow), установив параметры Graininess, Glow Amount и Clear 

Amount так, чтобы края изображения стали слегка размытыми.

10    После применения фильтра границы рисунка становятся менее 
четкими, как бы сливаясь с текстурой пирамиды.

11 Изменим фоновый цвет в панели инструментов на тон, близкий 
к фоновому цвету пирамиды. Для этого щелкнем по квадрату, 

отображающему цвет фона на панели инструментов, и инструментом 
Color Picker выберем на фотографии пирамиды подходящий оттенок. 
Это нужно для того, чтобы следующий фильтр взял за основу цвет, 
близкий к фону, то есть к пирамиде.

12 Следующий фильтр, который следует применить к слою с ри-
сунком, – это Spatter (меню Filter>Brush Strokes>Spatter). В окне 

предварительного просмотра устанавливаем Spray Radius и Smothness, 
(как и в прошлый раз), чтобы края изображения оказались слегка раз-
мытыми, но сам рисунок все же не утратил четкости.

7 С помощью команд Pespective, Rotate и Free Transform (меню Edit> 
Transform) изменим перспективу рисунка так, чтобы она соответс-

твовала перспективе фонового изображения.
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13 Как видно на примере, края рисунка практически слились с фо-
ном.

14 Убавим контрастность изображения до нуля, а яркость, на-
оборот, повысим до ста (меню Image>Adjustments>Brightness/

Contrast). Рисунок должен полностью исчезнуть с пирамиды.

15 Откроем диалоговое окно Blending Options (меню Layer>Layer 
Style>Blending Options).

16 Щелкнем по разделу Bevel and Emboss. Выбираем Style: Outer 
Bevel, Technique: Smooth, Depth: 100%, Size: 5 px, Soften: 0 px, 

Angle: 120, Altitude: 30, Highlight Mode: Screen, Shadow Mode: Multiply.

17 Получилось весьма убедительно. Но для более естественного 
и в то же время более заметного эффекта настроим парамет-

ры и Inner Shadow все в том же окне Layer Style. Выбираем Blend Mode: 
Multiply, Opacity: 50%, Angle: 120, Distance: 5, Choke: 0, Size: 15.

18 Теперь необходимо придать краям рельефа фактуру кирпичей. 
Для этого в окне Layer Style выбираем Texture. Из встроенных в 

программу текстур выбираем узор с кирпичами и настраиваем Scale 
(Масштаб) и Depth (Глубина) так, чтобы текстура естественным обра-
зом сливалась с фоном.
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19 Небольшая хитрость: чтобы подчеркнуть перспективу рисунка, 
применим стиль Gradient Overlay, настраиваемый из знакомого 

окна Layer Style.

20 Естественно, что обычный черно-белый градиент здесь не по-
дойдет. Щелкаем по линейке градиента, вызывая диалоговое 

окно настроек Gradient Editor. Изменяем цвета активных ограничителей 
цвета (маленькие квадратики на цветовой линейке в панели парамет-
ров Gradient Editor) на светло-коричневый (лучше выбрать цвет из са-
мой пирамиды инструментом Color Picker) и темно-коричневый.

21 Снизим Opacity (Непрозрачность) до 30.

22 Теперь возвратимся к черно-белому слою Background Copy.

23 Изменим режим наложения этого слоя на Soft Light. Это сделает 
все изображение более контрастным и завуалирует неточнос-

ти, если таковые имеются.

24 Теперь, когда основная часть работы над рисунком на пирамиде 
проделана, можно уменьшить яркость этого слоя (меню Image> 

Adjustments>Brightness/Contrast) до 30 – это придаст картине драма-
тичность.
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25 Объединим все слои на панели Layers с помощью команды 
Flattern Image.

26 И последние штрихи – инструментом Clone Tool с низкой непро-
зрачностью (20 или 30%) смягчим переходы от контуров рисун-

ка к текстуре пирамиды.

27 Таинственный рисунок, высеченный на поверхности пирамиды, 
готов!



Марго Григорян
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1 Откроем файл, над которым собираемся работать. Лучше всего 
подойдет снимок, где фигура четко отделяется от фона, как, напри-

мер, на этой фотографии черепахи в воде.

2 Двойным щелчком по слою Background в панели управления Layers 
вызываем диалоговое окно New Layer, в котором переименовыва-

ем слой в «оригинал».

3 Копируем слой «оригинал», создаем New Layer Set, куда помещаем 
копию слоя «оригинал», а слой «оригинал» перетаскиваем поверх 

сета.

4 Создаем два новых слоя: один заливаем полностью белым, другой 
– черным. Помещаем оба слоя под все остальные в панели управ-

ления Layers, причем нижним должен оказаться белый слой.

6 Теперь нужно решить, в какой части изображения разместить рам-
ку. Лучше сделать так, чтобы картинка словно «выпрыгивала» из 

фона. Когда решение принято, переходим к маске слоя «рамка» и вы-
деляем инструментом Rectangular Marquee прямоугольник размером с 
предполагаемую рамку.

5 Создаем новый слой, который называем «рамка». Помещаем его 
над всеми остальными слоями и включаем маску. Также включаем 

маску слоя «оригинал».
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9 Вырезаем выделенную область (Ctrl+X) и убираем линейку.

10    С помощью функции Perspective (меню Edit>Transform>Perspec-
tive) изменяем перспективу рамки по своему усмотрению.

11 Чтобы придать рамке больше динамики, можно ее слегка повер-
нуть с помощью функции Rotate (меню Edit>Transform>Rotate).

12 Чтобы добиться желаемого результата, можно также использо-
вать функцию Distort (меню Edit>Transform>Distort).

8 Включаем линейку или задаем команду Show Grid (меню View>Show> 
Grid). Внутри белого прямоугольника выделяем еще один, помень-

ше. Это определит ширину рамки, а линейка поможет сделать рамку 
ровной.

7 Заливаем прямоугольник белым цветом.
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13 Если во время трансформации рамка вышла за границы изоб-
ражения, необходимо немного увеличить размер полотна 

(Image>Canvas Size).

14 Щелкнув по пиктограммам глаза, выключаем белый и черный 
слои, а также слой «оригинал copy».

15 Переходим к слою «оригинал» и щелкаем по пиктограмме маски 
слоя. Затем выбираем большую кисть и аккуратно проводим ею 

по тем частям изображения, которые выходят за рамку. На этом эта-
пе делается черновое выделение, поэтому не следует слишком близко 
подступать к краям изображения в рамке.

16 Теперь увеличиваем масштаб изображения и мягкой кистью ма-
лого диаметра корректируем маску слоя так, чтобы полностью 

убрать остатки фона.

17 Выключаем черный слой – это поможет увидеть участки фона, 
которые остались неочищенными после маскирования.

18 Аккуратно избавляемся от указанных участков, а потом выклю-
чаем черный слой и включаем белый, чтобы окончательно убе-

диться в чистоте фона.
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19 Переходим к слою «рамка» и включаем черный слой.

20 Тем же способом, которым мы избавлялись от фона, стираем 
участки рамки, которые перекрывают изображение переднего 

плана.

22 Подобным же образом придаем тень слою «оригинал».

23 Создаем новый слой поверх всех остальных. На нем мягкой кис-
тью с непрозрачностью в 20-30% (Opacity) и в режиме наложе-

ния Multiply прорисовываем тени, падающие от черепахи на рамку.

24 Если необходимо увеличить изображение, то самое время за-
няться этим сейчас.

21 Применяем к слою «рамка» стиль слоя Drop Shadow (меню 
Layer>Layer Style>Drop Shadow). Настраиваем параметры сти-

ля по своему усмотрению, чтобы тень получилась не слишком резкой, 
но достаточно отчетливой.
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25 Выключаем видимость слоев «оригинал copy», «черный» и «бе-
лый» и применяем команду Merge Visible (Shift+Ctrl+E).

26 Инструментом Move Tool перетаскиваем изображение в полот-
не файла так, чтобы оно смотрелось гармонично.

27 Включаем видимость белого слоя и заливаем незаполненные 
области белым цветом. Кадрируем изображение и объединяем 

все слои командой Flattern Image.



Марго Григорян
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1 Откроем фотографию, над которой будем работать. Хорошо, если 
снимок достаточно темный – в этом случае падающие снежинки 

будут более заметны.

2 В панели Layers создадим новый набор слоев (Layer Set), который 
назовем «Снег». Затем внутри этого набора создадим новый слой.

3 Новый слой зальем 50% серым цветом.

4 Применим к этому слою фильтр Noise (меню Filter>Add Noise), вы-
ставив Amount – на 50%, Distribution – на Gaussian и отметив галоч-

кой Monochromatic.

6 Следующий фильтр – Torn Edges (меню Filter>Sketch>Torn Edges). 
Параметры Image Balance, Smoothness и Contrast установите по 

своему усмотрению, ориентируясь на то, что размер точек должен быть 
сопоставим с размером падающих снежинок.

5 Теперь к этому же слою применим фильтр Gaussian Blur (меню 
Filter>Blur>Gaussian Blur) со значением Radius в пределах 4-6 пик-

селов.
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8 Настроим кривые, как показано на рисунке.

9 Выбрав в панели  Layers набор слоев «Снег», изменим режим нало-
жения слоя на Screen и установим непрозрачность слоя (Opacity) 

80-90.

10    Теперь необходимо создать ощущение  глубины от падающих 
снежинок. Дублируем набор слоев «Снег» (меню Layer>Duplicate 

Layer Set).

11 Выделим все изображение в верхнем наборе слоев (Ctrl+A).

12 С помощью функции Scale (меню Edit>Transform>Scale) умень-
шим масштаб слоя до 50%.

7 Создадим корректирующий слой кривых (Curves) внутри набора 
слоев «Снег» (меню Layer>New Adjustments Layer>Curves).
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13 Снова, выделим все изображение на активном слое, после 
чего применим команду Top Edges, а затем Left Edges ( меню 

Layer>Align to Selection).

14 Продублируем слой, масштаб которого мы только что измени-
ли.

15 К продублированному слою применим команду Top Edges, а за-
тем Right Edges (меню Layer>Align to Selection). 

16 Объединим оба слоя, масштаб которых мы изменили, с помо-
щью команды Merge Down (Ctrl+E).

17 Подублируем этот слой и применим к нему команду Bottom 
Edges (меню Layer>Align to Selection), а затем объединим его со 

слоем Layer 2 командой Merge Down (Ctrl+E).

18 С помощью инструмента клонирования (Clone Stamp) аккуратно 
сотрем полоски, образовавшиеся на стыке масштабированных 

фрагментов.
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19 Снова продублируем набор слоев «Снег» (меню Layer>Duplicate 
Layer Set).

20 Выбрав на панели Layers слой Layer 3, выделим его (Ctrl+A) 
и применим команду Scale, как уже делали прежде (меню 

Edit>Transform>Scale), но на этот раз увеличим масштаб на 200% – на 
изображении появятся более крупные снежинки.

21 Изменим режим наложения верхнего набора слоев («Снег copy») 
на Soft Light – это вернет изображению контрастность, которая 

частично была утеряна за несколькими слоями.

22 К слою Layer 1 применим фильтр Motion Blur (меню Filter>Blur> 
Motion Blur) – угол движения (Angle)  и расстояние (Distance) ус-

тановите по своему усмотрению.

23 То же самое проделаем и со слоем Layer 3, однако здесь рассто-
яние (Distance) должно быть примерно в два раза меньше, чем 

на предыдущем слое.

24 Этот же фильтр применим к слою Layer 2, изменив на этот раз 
не только расстояние (Distance), на которое его необходимо 

уменьшить до 1-2 пикселов, но и угол движения (Angle) на пару десят-
ков градусов.
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25 Еще один фильтр, который необходимо применить к слою Layer 
2 – это Sprayed Strokes (меню Filter>Brush Strokes>Sprayed 

Strokes). Он придаст еще больше динамики падающим снежинкам. Па-
раметры фильтра необходимо отрегулировать в соответствии с осталь-
ными слоями.

26 Веренмся к слою Background и увеличим его контрастность с 
помощью уровней или кривых.

27 Объединим все слои командой Flattern Image (меню 
Layers>Flattern Image).



Марго Григорян
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1 Создаем новый  файл необходимого размера с белым фоном.

2 Включаем Grid (меню View>Show>Grid).

3 Инструментом Polygonal Lasso Tool аккуратно рисуем треугольник 
в соответствии с Grid.

4 Выбираем нужный цвет в Color Picker.

6 Grid можно отключить (меню View>Show>Grid).

5 Заливаем треугольник этим цветом.
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7 Снимаем выделение (Ctrl+D) и открываем диалоговое окно филь-
тра Shear (меню Filter>Distort>Shear).

8 Настраиваем кривую по своему усмотрению.

9 Применяем фильтр

10    Выделяем фигуру инструментом Magic Lasso Tool.

11 Копируем и помещаем в новый слой, а фигуру на слое Background 
удаляем, для чего нужно выбрать слой в панели Layers, выделить 

все изображение (Ctrl+A) и удалить (Delete).

12 Создаем новый слой. Удерживая Ctrl, щелкаем по слою с фигу-
рой в панели Layers – он будет выделен.
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13 Выбираем режим Airbrush в опциях инструмента Paint Brush, за-
даем большой размер кисти, Opacity и Flow на 50% и выбираем 

цвет того же оттенка, что и фигура, только светлее.

14 В новом слое аккуратно проводим кисть по середине фигуры, 
рисуя блик.

15 Применяем к новому слою фильтр Gaussian Blur (меню 
Filter>Blur>Gaussian Blur), установив радиус размытия на 5.

16 Создаем новый слой, уменьшаем кисть и выбираем еще более 
светлый оттенок. Теперь отрисовываем более светлый блик и 

применяем фильтр Gaussian Blur.

17 Создаем еще один новый слой и кистью более темного оттенка 
подчеркиваем затемненные участки. В завершение применяем 

фильтр Gaussian Blur, как и раньше.

18 Переходим обратно к слою с фигурой и применяем команду 
Stroke, выбрав темный цвет и установив параметр Location на 

Outside.
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19 Объединяем все слои, кроме фона, повторной командой Merge 
Down (Ctrl+E).

20 Теперь – самое интересное. Удерживая Ctrl, щелкаем по слою с 
фигурой. после того, как она будет выделена, ее нужно скопи-

ровать и несколько раз вставить в новые слои.

21 С каждым отдельным слоем проделываем ряд манипуля-
ций, таких как Free Transform (Ctrl+T), Flip Horizontal (меню 

Edit>Transform>Flip Horizontal). Можно также применить фильтр Shear, 
как мы уже делали.

22 Инструментом Move Tool перемещаем «щупальца» так, чтобы 
они пересекались. При этом основание должно оставаться за 

границами изображения.

23 Инструментом Eraser Tool, выбрав больший размер кисти и 
Opacity 10-20%, аккуратно проходимся по местам наложения 

«щупальцев» на каждом из слоев.

24 Объединяем все слои, коме слоя Background, последователь-
ной командой Merge Down (Ctrl+E).
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25 Применяем стиль слоя Drop Shadow (меню Layer>Layer 
Style>Drop Shadow), подкорректировав параметры по своему 

усмотрению.

26 К фону применяем градиент теплых тонов.

27 Объединяем все слои командой Flattern Image.
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1 Открываем фотографию, которую собираемся раскрасить. Ес-

тественно, чем лучшего качества будет черно-белая фотография, 

тем легче с нею будет работать.

2 Если это необходимо, корректируем Levels, чтобы изображение 

стало более четким (меню Image>Adjustments>Levels или Ctrl+L).

3 Фотографию требуется перевести в режим CMYK (меню 

Image>Mode>CMYK Color).

4 Теперь будем поочередно выделять разлтчные области на фото. 
Контуры у этой фотографии достаточно четкие, что позволит без 

труда произвести выделение инструментом Magnetic Lasso Tool, ко-
торый автоматически привязывает контур выделения к краю изобра-
жения переднего плана. Начнем с выделения кожи, захватывая также 
линию волос.

5 Если вас не устроит та или иная точка, нажмите Delete или 
Backspace – и она сотрется. Постепенно создавая контур с по-

мощью этого интесрумента, можно регулировать область выделения 
следующим образом: один щелчок задаст новую точку, а двойной щел-
чок закроет область выделения.

6 Если у вас еще остались невыделенные области, следует выде-

лить и их. Удерживая клавишу Shift, инструментом Magnetic Lasso 

обводим оставшиеся области.
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7 Теперь, удерживая клавишу Alt, выделяем глаза, брови и губы.

8 Чтобы подправить контуры выделения, переходим в режим быст-

рой маски (Quick Mask), удерживая клавишу «Q».

9 Инструментом Erase Tool добавляем в область выделения участ-
ки, пропущенные инструментом Magnetic Lasso. А инструментом 

Brush Tool убираем участки, которые нужно удалить из выделения. Ког-
да все будет готово, выходим из режима быстрой маски повторным 
нажатием «Q».

10  Создаем корректирующий слой с кривыми (меню Layer>New 
Adjustment Layer>Curves). Для удобства назовем его «кожа».

11  Поочередно выбирая цвета, настраиваем кривые таким обра-
зом, чтобы получить оттенок телесного цвета.

12  Теперь займемся волосами. Выделяем их интсрументом 
Magnetic Lasso Tool, как раньше выделили кожу.
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16  Настраиваем кривые, чтобы получить желаемый оттенок во-
лос.

17  А теперь выделяем губы.

18  Применяем фильтр Gaussian Blur и, если необходимо, в режи-
ме быстрой маски подправляем контуры.

13  Включаем режим быстрой маски и применяем к волосам 
фильтр Gaussian Blur сщ значением от 5 до 9 пискселов (меню 

Filter>Blur>Gaussian Blur).

14  Инструментами Brush Tool и Traser Tool подправляем границы 
выделения так, чтобы они не накладывались на кожу.

15  Выходим из режима быстрой маски и создаем еще один кор-
ректирующий слой – «волосы».
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19  Повторяем действия: выходим из режима быстрой маски, со-
здаем новый корректирующий слой и настраиваем кривые по 

своему усмотрению.

20  Аналогичным образом раскрашиваем брови.

21  Нельзя забывать о зубах – им тоже надо придать более ес-
тественный оттенок, слегка подняв кривую Yellow и опустив 

кривую Cyan.

22  Тем же способом придаем цвет глазам.

23  Поскольку платье выглядит на черно-белом снимке довольно 
светлым, выкрасим его в не слишком броский цвет.

24  Серьги, как и главзые яблоки, можно, конечно, оставить и бе-
лыми, но лучше придать им более теплый оттенок.
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25  Теперь, когда все участки закрашены, объединяем все слои 
воедино командой Flattern Image (меню Layer>Flattern Image).

26  Аккуратно обрабатываем границы между разными областя-
ми, которые не закрасились, с помощью интрумента Clone 

Stamp Tool.

27  А напоследок можно подкорректировать уровни по своему 
усмотрению.
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1 Создаем новый  документ.

2 Теперь нам понадобятся текстуры. Открываем файлы с заранее 
приготовленными текстурами – лучше всего подойдут текстуры 

старых поцарапанных металлических поверхностей.

3 Копируем одну из текстур и помещаем ее в новый документ 
(Ctrl+A>Ctrl+V).

4 Проделываем то же самое со второй текстурой.

6 Теперь нам понадобится фотография рамки.

5 В панели управления слоями меняем режим наложения верхнего 
слоя на Overlay и снижаем непрозрачность (Opacity) до 30%.



ÍÓÏÔ¸˛ÚÂÌ‡fl „‡ÙËÍ‡

äéåèúûÄêíA9.2005Photoshop: от простого к сложному. Часть 93: Портрет в стиле PhotoArt, стр. 53

8 Копируем рамку в наш документ.

9 Чтобы уменьшить размер рамки, прибегаем к команде Scale (меню 
Edit>Transform>Scale) и изменяем масштаб рамки до нужного раз-

мера, удерживая нажатой клавишу Shift.

10    Применяем фильтр Accented Edges (меню Filter>Brush Strokes> 
Accented Edges) с произвольными параметрами.

11 Нам понадобится дингбат (dingbat) с цветочными орнаментами. 
Мы использовали дингбат Flower Ornaments. Набираем один 

символ белым цветом.

12 С помощью команды Rotate (меню Edit>Transform>Rotate) пово-
рачиваем орнамент по своему усмотрению и затем инструмен-

том Move Tool передвигаем его в угол изображения.

7 Инструментом Magic Wand Tool выделяем фон от рамки и инверти-
руем выделение (меню Select>Inverse).
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13 В панели управления слоями меняем режим наложения верхне-
го слоя на Overlay.

14 Теперь набираем другой символ – на этот раз черным цветом.

15 Так же как и в случае с предыдущим элементом, поворачиваем 
орнамент, перемещаем аго по своему усмотрению, однако для 

черного узора режим наложения изменяем на Soft Light.

16 Продолжаем добавлять орнаменты по данному принципу, пока 
они не заполнят все поле за рамкой. К черным неизменно при-

меняем режим наложения слоев Soft Light, а к белым – Overlay.

17 Открываем заранее подготовленную портретную фотографию. 
Очень важно, чтобы фон фотографии был прозрачным.

18 Копируем фотографию и помещаем ее в рабочий документ так, 
чтобы край снимка девушки соприкосался с внутренним краем 

рамки.



ÍÓÏÔ¸˛ÚÂÌ‡fl „‡ÙËÍ‡

äéåèúûÄêíA9.2005Photoshop: от простого к сложному. Часть 93: Портрет в стиле PhotoArt, стр. 55

19 Изменяем при помощи команды Scale масштаб фотографии де-
вушки так, чтобы она идеально вписывалась в рамку.

20 Очень важно, чтобы цветовая гамма отдельных элементов порт-
ретного снимка совпадала с цветами фона и не дисгармониро-

вала. С этой целью изменим оттенок розы в волосах девушки на более 
темный и насущенный. Любым инструментом выделения выделяем 
цветок.

21 Настраиваем параметры цвета в диалоговом окне Selective 
Color (меню Image>Adjusrments>Selective Color).

22 Еще один способ быстро и просто изменить оттенок отдельного 
элемента изображения – воспользоваться командой Variations 

(меню Image>Adjustments>Variations). Превью-окно поможет лучше со-
риентироваться и выбрать нужный оттенок.

23 Точно таким же путем настраиваем цвет губ девушки.

24 Последний штрих – украшаем узором плечо девушки. Набира-
ем дингбат-символ белым цветом.
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25 Перемещаем его на плечо командой Rotate.

26 Инструментом Eraser Tool стираем участки, выступающие за 
контур плеча, предварительно растеризовав слой с дингбатом 

(меню Layer>Rasterize>Type).

27 В завершение – внимательно смотрим на композиуию и исправ-
ляем, если необходимо, фрагменты. Итак, мы изменили режим 

наложения слоя с рамкой на Darken. Готово!



Марго Григорян
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1 Создаем новый  документ.

2 Заливаем фон черным цветом

3 Выделяем прямоугольник инструментом Rectangular Marquee 
Tool.

4 Создаем новый слой (меню Layer>New>Layer). Для удобства его 
можно назвать «Пергамент».

6 Убираем выделение (Ctrl+D) и применяем к слою «Пергамент» 
фильтр Spatter (меню Filter>Brush Strokes>Spatter), установив зна-

чения так, чтобы получился эффект рваных краев. Очень важно, чтобы 
на панели инструментов был выбран черный цвет фона (Background 
Color).

5 Заливаем выделение желтоватым цветом, напоминающим цвет 
старого пергамента.
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8 Теперь следует применить фильтр Pinch (меню Filter>Distort>Pinch), 
чтобы слегка растянуть края пергамента. Параметры можно выби-

рать по своему усмотрению, руководствуясь окном Preview.

9 Еще один фильтр – Shear (меню Filter>Distort>Shear). Кривую не-
обходимо настроить в зависимости от того, насколько вы хотите 

исказить перспективу листа пергамента.

10    И последним применяем фильтр Sumi-e (меню Filter>Distort> 
Sumi-e), чтобы смягчить рваные края. Параметры настраивайте 

по своему усмотрению – они во многом зависят от размера файла.

11 Выделяем инструментом Magic Wand Tool будущий лист перга-
мента, затем инвертируем выделение (Shift+Ctrl+I) и нажимаем 

клавишу Delete. Это необходимо для того, чтобы избавиться от черных 
краев вокруг листа пергамента.

12 Убираем выделение (Ctrl+D) и открываем диалоговое окно Layer 
Style (меню Layer>Layer Style). Выбираем параметр Pattern 

Overlay, находим текстуры Artist Surfaces и выбираем вторую справа 
текстуру во второй строке.

7 Следующий фильтр – Accented Edges (меню Filter>Brush Strokes> 
Accented Edges). Значение Edge Width следует установить на мак-

симум, а Brightness и Smoothness – на минимум.
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13 Все бы хорошо, но после применения этого стиля пропал цвет 
пергамента. Чтобы восстановить его, используем еще один 

стиль – Color Overlay.

14 Теперь нам нужно объединить все примененные стили в один 
слой. Для этого воспользуемся командой Create Layers (меню 

Layer>Layer Style>Create Layer).

15 Отключаем пиктограмму глаза в панели управления Layers на 
слое Background и объединяем слои командой Merge Visible 

(Ctrl+Shift+E).

16 Снова включаем видимость слоя Background. Теперь создадим 
загнутый уголок – это придаст листу большую реалистичность. 

Для этого выделяем инструментом Magic Lasso Tool уголок пергамен-
та, не заботясь об аккуратности выделения.

17 Удерживая нажатой клавишу Alt, инструментом Magic Wand Tool 
убираем лишнее из выделения.

18 Вырезаем выделение (Ctrl+X) и помещаем уголок листа в но-
вый слой.
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19 Применяем команду Flip Horizontal (меню Edit>Transform>Flip 
Horizontal), а затем переворачиваем уголок вручную (меню 

Edit>Transform>Rotate) и слегка деформируем его (меню Edit> 
Transform>Skew).

20 Далее инструментом Move Tool перемещаем уголок так, чтобы 
его край и край листа совпали.

21 Применяем к этому слою стиль Drop Shadow (меню Layer>Layer 
Style).

22 Очень важно слегка разнообразить текстуру. После применения 
стиля с текстурой на пергаменте рисунок повторяется. Чтобы 

замаскировать повторяющиеся элементы, воспользуемся инструмен-
том Clone Tool и как следует пройдемся им по всему листу на слое «Пер-
гамент».

23 Хорошо бы «продырявить» пергамент в нескольких местах: для 
этого нарисуем произвольные дырки с рваными контурами инс-

трументом Lasso Tool (можно также захватить края листа), а затем со-
трем область выделения.

24 Инструментом Burn Tool (с параметрами Range: Shadows и 
Exposure – 25-75%) прорисовываем контуры дырок и края лис-

та сначала кистью большого размера, а затем – более маленькой. Па-
раметр Exposure также следует изменять от меньшего к большему по 
мере уменьшения диаметра кисти.
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25 Выбираем в палитре кистей кисть с рваными краями, устанав-
ливаем большой диаметр и проходимся инструментом Burn 

по всей площади листа во всех трех режимах – Highlight, Shadows, 
Midtones.

26 Объединяем все слои командой Flattern Image (меню 
Layer>Flattern Image).

27 В завершение слегка уменьшаем насыщенность цветов (меню 
Image>Adjustmsnts>Hue Saturation). Готово!



Марго Григорян
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1 Открываем файл, который собираемся использовать как фон для 
текста (о том, как создавать подобный лист старого пергамента 

рассказано в предыдущем уроке).

2 Помещаем текст в новый слой.

3 Заменяем шрифт на каллиграфический. В данном примере это GE 
Quilt Script.

4 Инструментом Move Tool перемещаем блок текста на середину 
листа.

6 Настраиваем кегль шрифта; в нашем примере это 27.

5 Настраиваем расстояние между строками, включив панель управ-
ления Character (меню Window>Character) по своему усмотрению. 

В данном примере использована величина 20 pt.
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8 Выделяем весь слой с текстом.

9 Помещаем скопированный текст в новый слой.

10    Инструментом Move Tool перемещаем текст так, чтобы он с не-
большим смещением перекрывал первый слой с текстом.

11 Применяем к слою фильтр Colored Pencil (меню Filter> 
Artistic>Colored Pensil), выставив Stroke Pressure на максимум, 

Paper Brightness на минимум, а Pensil Width оставив примерно на 5-7.

12 Придаем буквам более чернильный оттенок. Открываем диа-
логовое окно  Hue/Saturation (меню Image>Adjustments>Hue/

Saturation) и настраиваем параметры следующим образом: Hue - 212, 
Saturation - 74, Lightness - +4.

7 Растеризуем слой с текстом (панель управления слоями; Rasterize 
Layer).
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13 Отключаем видимость слоя с листком пергамента, щелкнув по 
пиктограмме глаза в панели управления Layers, и склеиваем 

слои с текстом (Ctrl+Shift+Alt+E).

14 Снова включаем видимость слоя с пергаментом и дублируем 
новый слой (меню Layer>Duplicate Layer).

15 Открываем диалоговое окно Layer Style (меню Layer>Layer 
Style), выбираем функцию Stroke, Fill Type устанавливаем на 

Color. Щелкнув по прямоугольнику с цветом, выбираем темно-синий 
оттенок.

16 Устанавливаем Size на 2, Position на Outside, Blend Mode на Hard 
Light, а Opacity оставляем 100%.

17 Отключаем видимость верхнего слоя, возвращаемся к слою 
Layer 1 и слегка изменяем его цвет с помощью настройки па-

раметров Hue/Saturation (меню Image>Adjustments>Hue/Saturation). 
Включив режим Colorize, устанавливаем Hue на 300, а Saturation – на 
80.

18 Возвращаемся к верхнему слою. Выбираем большую мягкую 
кисть и стираем текст в нескольких местах так, чтобы прогля-

дывал нижний слой с фиолетовым текстом. Время от времени можно 
менять Opacity (непрозрачность) кисти для достижения более реалис-
тичного эффекта.
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19 Переходим к самому первому текстовому слою и также стира-
ем текст в некоторых местах, чтобы создать эффект выцветших 

чернил.

20 То же самое проделываем на слое Layer 1.

21 Отключаем видимость слоя с пергаментом и объединяем все 
слои с текстом (Ctrl+Shift+E).

22 Снова включаем видимость слоя с пергаментом и открываем 
диалоговое окно Liquify.

23 Инструментом Turbulence Tool с помощью большой кисти со-
здаем небольшие искажения: текст не должен быть идеально 

ровным. Особенно важно уделять внимание заглавным буквам: они не 
должны выглядеть абсолютно одинаково.

24 Добавляем искажения с помощью нескольких других инстру-
ментов: Forward Wrap Tool, Bloat Tool и Pucker Tool. Размер и ин-

тенсивность нажатия кисти регулируем по своему усмотрению.
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25 Инструментом Eraser Tool аккуратно стираем часть буквы, ока-
завшуюся поверх сложенного уголка.

26 Осталось поставить несколько «клякс». Выбираем кисть нестан-
дартной формы и чернильным цветом рисуем кляксы, периоди-

чески меняя размер и непрозрачность кисти, а также оттенок «чернил». 
Чтобы получить эффект чернильных подтеков, устанавливаем большой 
размер кисти.

27 В завершение проходимся инструментом Blur Tool по некото-
рым участкам текста, чтобы создать эффект легкой размытости 

чернил.



Марго Григорян
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1 Открываем фотографию, над которой собираемся работать.

2 Инструментом «лассо» (Lasso Tool) выделяем левый глаз девушки. 
Помните, что вокруг выделяемой области должно оставаться не-

много кожи.

3 Копируем выделенную область и помещаем в новый слой.

4 Переименовываем слой в «Левый глаз».

6 Теперь аккуратно выделяем губы и повторяем все то же самое.

5 Таким же образом поступаем с другим глазом: выделяем, копиру-
ем, помещаем в новый слой, который называем соответственно 

«Правый глаз».
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8 И под конец выделяем брови.

9 Отключаем видимость всех слоев, кроме фонового (Background), 
щелкнув по пиктограмме глаза в панели управления Layers.

10    Инструментом клонирования переносим фактуру кожи поверх 
бровей, чтобы полностью стереть их с лица.

11 Чтобы сгладить неровности, образовавшиеся на тектуре кожи 
вследствие клонирования, используем инструмент Patch Tool. 

Выделяем область, где раньше были брови, и аккуратно перетаскиваем 
текстуру кожи с соседнего участка.

12 Чтобы скрыть губы, сначала на лбу выделяем прямоугольный 
участок, по размеру приблизительно совпадающий с губами.

7 Так же поступаем и с носом, выделив его от переносицы.
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13 Копируем его, помещаем в новый слой поверх слоя Background 
и перемещаем инструментом Move Tool поверх губ.

14 Используя большую мягкую кисть инструмента Erazer Tool, сти-
раем  границы скопированной области.

15 Слегка подправляем уровни (Levels), чтобы приблизить оттенок 
данного участка к цвету кожи.

16 Выполняем команду Merge Down для склеивания этого слоя со 
слоем Background.

17 Инструментом Clone Tool корректируем данный участок таким 
образом, чтобы его текстура полностью слилась с текстурой 

кожи.

18 С помощью все того же Clone Tool стираем кончик носа.
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19 Получилось нечто похожее на кадр из фильма ужасов. А теперь 
– самое главное: будем постепенно возвращать на место черты 

лица.  Включаем видимость слоя «Левый глаз». Нажимаем Ctrl+T, в па-
нели  параметров инструмента включаем опцию Maintain Aspect Ratio и 
увеличиваем масштаб участка на 150%.

20 Передвигаем глаз чуть ближе к краю овала лица и большой мяг-
кой кистью стираем границы участка.

21 Так же поступаем и с правым глазом.

22 Теперь возвращаем на место губы, но, в отличие от глаз, их нуж-
но сделать меньше – здесь можно не включать опцию Maintain 

Aspect Ratio.

23 Работаем над носом, который тоже следует  слегка уменьшить – 
около 70% по ширине, не включая опцию Maintain Aspect Ratio.

24 И, наконец, брови. Их лучше всего изменить с помощью ручной 
перенастройки перспективы. Нажимаем Ctrl+T, правым щелч-

ком мыши вызываем меню, выбираем Perspective и изменяем выбран-
ный участок по своему усмотрению.
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25 После этого стираем резкие границы.

26 Объединяем все слои командой Flattern Image (меню Layer). 
Выделяем изображение и изменяем перспективу всей фото-

графии, слегка вытянув ее вниз.

27 Кадрируем изображение инструментом Crop Tool. Напоследок 
инструментом Sponge в режиме Saturate можно подчеркнуть 

губы, глаза и волосы, а также наложить румянец.


